Orbee's analytics services will work on IE, but Orbee’s On-Site plugins are not supported due to IE’s limited compatibility.

Due to the low prevalence of Internet Explorer(IE) among our end users, Orbee has decided to not support IE for On-Site plugins. IE has limited compatibility, which creates difficulties when it populates elements on a website.

It is important to remember that this does not mean we can not track IE users. Analytics services are still going to be supported by Internet Explorer users.

Did this answer your question?